Форумы|Программирование на PHP
проблема с кодировкой.. помогите)

<<Пред. | След.>>
1,2
Сообщения
1. ecco[102](Off)Отв|Цит|ЛС
28 Апр 2013, 17:56
загрузил я скрипт, установил http://igru6ek.ru/blogs теперь, когда пишу заметку или создаю тему, вместо букв появляются знаки, можете проверить http://igru6ek.ru/blogs/index.php?page=blogs&id=1&dir=xhtml сколько уже менял кодировку всех файлов скрипта и таблиц ничего не помогает. почему?
2. Aventus[328](Off)Отв|Цит|ЛС
28 Апр 2013, 18:00
ecco, поменяй кодировку самой БД.
3. ecco[102](Off)Отв|Цит|ЛС
28 Апр 2013, 18:13
не могли бы уточнить как? что-то я не найду в пхпмайадмин
4. Aventus[328](Off)Отв|Цит|ЛС
28 Апр 2013, 18:30
...
5. rus21d[27](Off)Отв|Цит|ЛС
28 Апр 2013, 18:52
везде поставь utf8,
в скрипте, при конекте к базе, и файлы перекодируй, точно должно помочь
6. Avarskiy[117](Off)Отв|Цит|ЛС
28 Апр 2013, 18:59
ecco, А в самой базе как отображены? Нормально? Только при выводе такие иероглифы?
7. ecco[102](Off)Отв|Цит|ЛС
28 Апр 2013, 19:13
в базе тоже иероглифы.. ну в смысле таблицы нормально, но значения в них, например users под именем иероглифы(т. к. при регистрации вводил русскими)
добавлено спустя 5 минут:
Aventus, нашел, исправил, все равно так(
8. Casper[2023](Off)Отв|Цит|ЛС
28 Апр 2013, 19:21
ecco, Теперь посмотри в самой базе нормальное отображение? Если нормальное, то попробуй в файл .htaccess добавить строчку в самом верху: AddDefaultCharset UTF-8
9. ecco[102](Off)Отв|Цит|ЛС
28 Апр 2013, 19:32
блин, та же беда
10. GercoG[37](Off)Отв|Цит|ЛС
28 Апр 2013, 19:36
Дай скрин структуры бд из phpMyAdmin

<<Пред. | След.>>
1,2

Эта тема закрыта, вы не можете писать ответы и редактировать сообщения.
Сохранить в txt